Segway Forum banner
1 - 7 of 7 Posts

·
Registered User
Joined
·
1 Posts
Discussion Starter · #1 ·
Have this 2020 Sagway snarler at6s that has 326km on it. Completed first service at 300km and cracked Downpipe. Sinced replace, the quad has no loss of power, stalls the odd time and doesn’t have the 4wd diagram showing on its cluster. Traced fuses and dealer has had the quad for over 2 months, returned it back to me with these lights still on saying “drive it 2kms and watch it restart”. 26kms since full service and once over and vehicle still flashing oil pressure and opc ( 4wd picture/symbol not appearing on cluster ) ANY ADVICE?
 

·
Registered User
Joined
·
59 Posts
Have this 2020 Sagway snarler at6s that has 326km on it. Completed first service at 300km and cracked Downpipe. Sinced replace, the quad has no loss of power, stalls the odd time and doesn’t have the 4wd diagram showing on its cluster. Traced fuses and dealer has had the quad for over 2 months, returned it back to me with these lights still on saying “drive it 2kms and watch it restart”. 26kms since full service and once over and vehicle still flashing oil pressure and opc ( 4wd picture/symbol not appearing on cluster ) ANY ADVICE?
Welcome to the forum @Simply.pedro! What exactly did the dealer do when they looked over your Snarler? Did the reset or replace anything?
 

·
Registered User
Joined
·
1 Posts
Have this 2020 Sagway snarler at6s that has 326km on it. Completed first service at 300km and cracked Downpipe. Sinced replace, the quad has no loss of power, stalls the odd time and doesn’t have the 4wd diagram showing on its cluster. Traced fuses and dealer has had the quad for over 2 months, returned it back to me with these lights still on saying “drive it 2kms and watch it restart”. 26kms since full service and once over and vehicle still flashing oil pressure and opc ( 4wd picture/symbol not appearing on cluster ) ANY ADVICE?
Hi im having the same problem oil light flashing only had the bike 1 week only done 50 miles what was wrong with yours ? Im hoping its just a faulty sensor 🤞
 

·
Registered User
Joined
·
1 Posts
so i brought my snarler into the dealer and it had the ocasional oil light flash but it always went away and i also had stalled twice. (2 times in 15 hours usage) so i didnt think anything of it. When i brought it into the dealer for my first service, they noticed one of the seals was cracked and leaking oil. they fixed that under warranty no problem. fast forward 2 weeks, my oil light is flashing like crazy and its leaking oil in my driveway. the dealer has since picked up the bike and are working on it again. is been 3 days no news so far. i could imagine there must be a manufacturer defect on this.
 

·
Registered User
Joined
·
2 Posts
I bought a Segway Snarler AT6 the long wheel base in the beginning of december and having problem with flashing oil pressure light.
I solved it by pushing the oil pressure sensor contact towards the sensor/engine and tied it with a ziptie which i guess enhance the contact.

I also have problems with changing gear while the transmission is at resistance, for instance standing in a hill, or when i’m plowing snow.
I have to use force to change gear D to R or get the driveline free from resistance before changing gear.
It almost feels like i’m bending the gearstick.
When the driveline is without resistance it works properly.
Does anyone else experienced the same with the gears?
 
1 - 7 of 7 Posts
Top